Email Sending Outage
Incident Report for UserLoop
Postmortem

A merchant on UserLoop sending a large volume of emails was flagged by our email provider (Postmark) due to an increase in the number of spam reports on those emails.

Whilst emails sent on UserLoop typically have a very low level of spam reports, this particular merchant pushed us as a whole over the threshold.

Postmark then blocked sending for all UserLoop emails. Whilst we addressed this issue and paused sending for this merchant, Postmark objected to us using their ‘transactional' email API and eventually asked that we used their 'broadcast' API instead.

Once we had established this was the reason for our account being paused and all emails in the queue being deleted we made the switch to use the 'broadcast’ API.

This resulted in approximately 6 hours of downtime in email being sent to customers, emails triggered during this time will not be sent.

We have taken actions to automatically identify merchants with an unusually number of spam reports so we can automatically pause their email sending in future without impacting all merchants.

Posted Feb 02, 2023 - 15:24 UTC

Resolved
Survey emails are not being sent due to an issue with our email provider.
Posted Feb 02, 2023 - 00:00 UTC